dotProject Forums

Go Back   dotProject Forums > DOTPROJECT VERSION 2 > Customisation Questions 2.x
Register FAQTop Posters Members List Calendar Search Today's Posts Resend Activation Email Mark Forums Read
dotProject Documentation dotProject FAQ Bugs & Feature Requests Language Packs & Themes Download dotProject

Customisation Questions 2.x How do you modify ..... for your own site

Reply
 
Thread Tools Display Modes
  #1  
Old 01-12-07, 10:22 AM
kurios kurios is offline
Junior Member
Return Visitor
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 30-11-07
Posts: 5
Default IIS PHP MySQL - very slow

Greetings everyone,

I am semi-new to the open source community as I have done some PHP development in Linux but I am anymore these days just a Microsoft Developer. I know IIS, ASP.NET, and SQL Server very well, but PHP and MySQL running on IIS would be new territory to me.

The Problem: dotProject is very slow!
Everything from hitting the login page to clicking on the navigation or clicking on anything, there is about a 6-10 second delay between post backs. I have tried a few optimizations, including the "output_buffering = On" but no avail. I hadmy web hosting company look in to bandwidth issues, but that doesn't seem to be the case.

The install went fine with the exception of making the config.php writable from the IUser which was fixed later manually. My system information is as follows:

dotProject Version 2.1.1
Windows 2003 Server IIS6
PHP Version 5.2.0
MySQL Version 5.0.22


System Windows NT DEDI506 5.2 build 3790
Build Date Nov 2 2006 11:50:55
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"
Server API CGI/FastCGI
Virtual Directory Support enabled
Configuration File (php.ini) Path D:\hosting\member\myuser\Project\php-cgi-fcgi.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, compress.zlib, compress.bzip2, https, ftps
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*, bzip2.*

I realize that dotProject is officially "unsupported" for IIS but some of you have gotten this to work, so here I am, trying as well. If anyone has any information, even if you think I am wasting my time trying to get dotProject to run faster in my environment, please tell me. I've already spent 3 days researching and I will continue to do so a bit longer.

Thanks in advance.
kurios

Reply With Quote
  #2  
Old 01-12-07, 11:29 AM
ajdonnison's Avatar
ajdonnison ajdonnison is offline
Administrator
Utter Fanatic
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 13-04-04
Posts: 2,251
Default Re: IIS PHP MySQL - very slow

It is known that PHP is slow on Windows, and I believe MS are actually working to resolve that, although I have not heard of such extreme performance problems. You may want to check that you aren't having other issues like DNS lookup problems (which tends to be the most common cause of slow websites). If your database server is not 'localhost' then DNS lookups there can also be a hidden cost.
Reply With Quote
  #3  
Old 02-12-07, 11:39 AM
kurios kurios is offline
Junior Member
Return Visitor
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 30-11-07
Posts: 5
Default Re: IIS PHP MySQL - very slow

Hi ajdonnison,

Thank you for your input. I tried using a direct IP address and pretty much the same results. I know I can't have localhost as I'm pretty sure the web hosting company has 2 servers involved. I'm half tempted to look into FREE web hosting for PHP and MySQL.

Again, thank you ajdonnison for your input, let me know if you think of something else.

kurios

Reply With Quote
  #4  
Old 03-12-07, 12:22 PM
kurios kurios is offline
Junior Member
Return Visitor
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 30-11-07
Posts: 5
Default Re: IIS PHP MySQL - very slow

Greetings everyone,

Still no progress, but I did want to leave a few pieces of info incase anything sticks out. This is my pho-cgi-fcgi.ini file in the slim version as there was LOTS of comments I took out for space reasons. Let me know if anything sticks out. Thanks, kurios

[php]

engine = Off
zend.ze1_compatibility_mode = Off
short_open_tag = On
asp_tags = Off
precision = 12
y2k_compliance = On
output_buffering = On
zlib.output_compression = Off
implicit_flush = Off
unserialize_callback_func=
serialize_precision = 100
allow_call_time_pass_reference = Off
safe_mode = Off
safe_mode_gid = Off
safe_mode_include_dir =
safe_mode_exec_dir =
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
disable_functions =
disable_classes =

expose_php = On

max_execution_time = 60 ; Maximum execution time of each script, in seconds
max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
memory_limit = 16M ; Maximum amount of memory a script may consume (16MB)

error_reporting = E_ALL & ~E_NOTICE
display_errors = On
display_startup_errors = On
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off

variables_order = "EGPCS"
register_globals = Off
register_long_arrays = On
register_argc_argv = Off
auto_globals_jit = On
post_max_size = 8M
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
auto_prepend_file =
auto_append_file =
default_mimetype = "text/html"

doc_root =
user_dir =
extension_dir = "c:\php5"
enable_dl = Off
cgi.force_redirect = 0
file_uploads = On
upload_tmp_dir = c:\php5\uploadtemp
upload_max_filesize = 8M
allow_url_fopen = On
allow_url_include = Off
default_socket_timeout = 60

extension=php_mbstring.dll
extension=php_bz2.dll
extension=php_curl.dll
extension=php_dba.dll
extension=php_dbase.dll
extension=php_exif.dll
extension=php_fdf.dll
extension=php_gd2.dll
extension=php_gettext.dll
extension=php_imap.dll
extension=php_interbase.dll
extension=php_ldap.dll
extension=php_mcrypt.dll
extension=php_mhash.dll
extension=php_mime_magic.dll
extension=php_ming.dll
extension=php_mssql.dll
extension=php_msql.dll
extension=php_mysql.dll
extension=php_openssl.dll
extension=php_pgsql.dll
extension=php_shmop.dll
extension=php_snmp.dll
extension=php_sockets.dll
extension=php_tidy.dll
xtension=php_xmlrpc.dll
extension=php_xsl.dll

[Date]

[filter]

[iconv]

[sqlite]

[xmlrpc]

[Pcre]

[Syslog]
define_syslog_variables = Off

[mail function]
SMTP = localhost
smtp_port = 25
sendmail_from = phpbot@mysite4now.com

[SQL]
sql.safe_mode = Off

[ODBC]
odbc.allow_persistent = On
odbc.check_persistent = On
odbc.max_persistent = -1
odbc.max_links = -1
odbc.defaultlrl = 4096
odbc.defaultbinmode = 1

[MySQL]
mysql.allow_persistent = On
mysql.max_persistent = -1
mysql.max_links = -1
mysql.default_port =
mysql.default_socket =
mysql.default_host =
mysql.default_user =
mysql.default_password =
mysql.connect_timeout = 60
mysql.trace_mode = Off

[MySQLi]
mysqli.max_links = -1
mysqli.default_port = 3306
mysqli.default_socket =
mysqli.default_host =
mysqli.default_user =
mysqli.default_pw =
mysqli.reconnect = Off

[mSQL]
msql.allow_persistent = On
msql.max_persistent = -1
msql.max_links = -1

[PostgresSQL]
pgsql.allow_persistent = On
pgsql.auto_reset_persistent = Off
pgsql.max_persistent = -1
pgsql.max_links = -1
pgsql.ignore_notice = 0
pgsql.log_notice = 0

[Sybase]
sybase.allow_persistent = On
sybase.max_persistent = -1
sybase.max_links = -1
sybase.min_error_severity = 10
sybase.min_message_severity = 10
sybase.compatability_mode = Off

[Sybase-CT]
sybct.allow_persistent = On
sybct.max_persistent = -1
sybct.max_links = -1
sybct.min_server_severity = 10
sybct.min_client_severity = 10

[bcmath]
bcmath.scale = 0

[browscap]
browscap = c:\php5\extras\php_browscap.ini

[Informix]
ifx.default_host =
ifx.default_user =
ifx.default_password =
ifx.allow_persistent = On
ifx.max_persistent = -1
ifx.max_links = -1
ifx.textasvarchar = 0
ifx.byteasvarchar = 0
ifx.charasvarchar = 0
ifx.blobinfile = 0
ifx.nullformat = 0

[Session]
session.save_handler = files
session.save_path = c:\php5\sessiondata
session.use_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.cookie_httponly =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
session.bug_compat_42 = 0
session.bug_compat_warn = 1
session.referer_check =
session.entropy_length = 0
session.entropy_file =
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
session.hash_function = 0
session.hash_bits_per_character = 5
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fields et="

[MSSQL]
mssql.allow_persistent = On
mssql.max_persistent = -1
mssql.max_links = -1
mssql.min_error_severity = 10
mssql.min_message_severity = 10
mssql.compatability_mode = Off
mssql.secure_connection = Off

[Assertion]

[COM]

[mbstring]

[FrontBase]

[gd]

[exif]

[Tidy]
tidy.clean_output = Off

[soap]
soap.wsdl_cache_enabled=1
soap.wsdl_cache_dir="/tmp"
soap.wsdl_cache_ttl=86400

[Zend]
zend_extension_ts = c:\php5\ioncube_loader_win_5.2.dll
zend_extension_manager.optimizer_ts="C:\php5\Optim izer-3.2.2"
zend_extension_ts="C:\php5\ZendExtensionManager.dl l"

Reply With Quote
  #5  
Old 03-12-07, 12:42 PM
ajdonnison's Avatar
ajdonnison ajdonnison is offline
Administrator
Utter Fanatic
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 13-04-04
Posts: 2,251
Default Re: IIS PHP MySQL - very slow

This might seem counter-intuitive, but you may want to try and disable the Zend optimizer:
Quote:
[Zend]
zend_extension_ts = c:\php5\ioncube_loader_win_5.2.dll
zend_extension_manager.optimizer_ts="C:\php5\Optim izer-3.2.2"
zend_extension_ts="C:\php5\ZendExtensionManager.dl l"
You just need to add a semi-colon ( before each line. This will simply remove this as a possible source of problem, and although I doubt it will help it at least isolates it.
Reply With Quote
  #6  
Old 05-12-07, 12:49 PM
kurios kurios is offline
Junior Member
Return Visitor
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 30-11-07
Posts: 5
Default Re: IIS PHP MySQL - very slow

Hi ajdonnison,

Unfortunately...no luck... thank you for the suggestion. I'm getting a bad vibe about MySQL and PHP. I know PHP runs fast on IIS, I tested it with another php app. I installed ISense and it too has the 6-10 second delay (even longer when just hitting the login page).

So my suspicions turn to MySQL configuration with PHP. I don't quite know where the bottlenecks could be... any ideas?

Thanks,
kurios

Reply With Quote
  #7  
Old 05-12-07, 01:31 PM
ajdonnison's Avatar
ajdonnison ajdonnison is offline
Administrator
Utter Fanatic
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 13-04-04
Posts: 2,251
Default Re: IIS PHP MySQL - very slow

The only time I've seen slow response like that from MySQL with PHP is when MySQL is doing reverse DNS lookups to handlle the access controls. If this is the case you can add the following to your my.cnf (or my.ini as the case may be):
Code:
skip-name-resolve
It may also be that there is a sub-optimal MySQL configuration, although even the worst config should still give you sprightly performance with PHP.
Reply With Quote
  #8  
Old 16-12-07, 07:09 AM
kurios kurios is offline
Junior Member
Return Visitor
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 30-11-07
Posts: 5
Default Re: IIS PHP MySQL - very slow

I haven't forgotten about this thread...its just that my hosting company I think has forgotten about me. I highly recommended the skip-name-resolve, but they haven't gotten back to me. I'm about to write an email to their CEO about service issues.

kurios

Reply With Quote
  #9  
Old 13-10-08, 12:49 PM
shafeeq shafeeq is offline
Junior Member
New Participant
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 09-08-08
Posts: 1
Smile Re: IIS PHP MySQL - very slow

Just to let you know that I had the same problem and having included the skip-name-resolve in the my.ini has resolved my issue and made a huge performance difference!

Shafeeq

Reply With Quote
  #10  
Old 06-07-09, 11:30 PM
rhys9tt rhys9tt is offline
Junior Member
New Participant
dotProject Version:
php Version:
MySQL Version:
Operating System Version:
Browser:
 
Join Date: 06-07-09
Posts: 1
Default Re: IIS PHP MySQL - very slow

hi

i havew the same issue with php running very slow in iis7 using php 5.2.6

any ideas?

also where does the my.ini or my.cnf live? I cant find any reference to these

Hope you can help

Rhys

Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +10. The time now is 06:41 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.